Database support

From PhiWiki
Jump to: navigation, search
Pagedb.png

With Phi you have a build in support for all major database management systems.

Supported DBMS

  • QDB2 IBM DB2 (version 7.1 and above)
  • QIBASE Borland InterBase
  • QMYSQL MySQL
  • QOCI Oracle Call Interface Driver
  • QODBC Open Database Connectivity (ODBC) - Microsoft SQL Server and other ODBC-compliant databases
  • QPSQL PostgreSQL (versions 7.3 and above)
  • QSQLITE2 SQLite version 2
  • QSQLITE SQLite version 3
  • QTDS Sybase Adaptive Server

DB installation

Unfortunately it is not possible for us to bundle all drivers with the PhiSuite due to restrictions from the database vendors. You need to install the database client libraries by yourself if you do not find the required entries in the dropdown list. Please refer to the installation notes of each DB vendor.

It also might be necessary to compile the related Qt SQL driver plug-in. Maybe you find this documentation useful: Qt SQL driver.

If you need further assistance please contact us.